aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-rpio
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-14 21:09:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-17 15:01:33 +0000
commit589ce857e4d8b4ab54437214ab9caaf441965295 (patch)
tree60be8c35536d5b816948a6086a5c92a13936db3d /testing/py-rpio
parent1461302280c66182e2f18bd85829a650d9175c4f (diff)
downloadaports-589ce857e4d8b4ab54437214ab9caaf441965295.tar.bz2
aports-589ce857e4d8b4ab54437214ab9caaf441965295.tar.xz
testing/py-rpio: new aport
GPIO toolbox for the Raspberry Pi https://github.com/metachris/RPIO
Diffstat (limited to 'testing/py-rpio')
-rw-r--r--testing/py-rpio/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-rpio/APKBUILD b/testing/py-rpio/APKBUILD
new file mode 100644
index 0000000000..26da2be375
--- /dev/null
+++ b/testing/py-rpio/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-rpio
+_pkgname=RPIO
+pkgver=0.10.0
+pkgrel=0
+pkgdesc="GPIO toolbox for the Raspberry Pi"
+url="https://github.com/metachris/RPIO"
+arch="all"
+license="LGPLv3+"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="cefc45422833dcafcd59b78dffc540f4 RPIO-0.10.0.tar.gz"
+sha256sums="b89f75dec9de354681209ebfaedfe22b7c178aacd91a604a7bd6d92024e4cf7e RPIO-0.10.0.tar.gz"
+sha512sums="6b366d47809e0f1b3733316821bdebd02a202cdf4a31f67fda07aa806cfcf546bd2a38644e25d481ec0d6fd2210ea697fdc0d0f3e57340ab40d81d7e275f483c RPIO-0.10.0.tar.gz"