aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-tqdm
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-12-26 19:04:17 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-26 19:15:56 +0100
commit37f3ac9ad492ea3342f95aa5ea34f71a1314814f (patch)
tree0ce0ec5cc30bb3aa3786e9c1ae18afcc636044b5 /testing/py-tqdm
parentd402cf57dcfeec62732c197df64b5985d7431958 (diff)
downloadaports-37f3ac9ad492ea3342f95aa5ea34f71a1314814f.tar.bz2
aports-37f3ac9ad492ea3342f95aa5ea34f71a1314814f.tar.xz
testing/py-tqdm: disable perf tests on aarch64
Diffstat (limited to 'testing/py-tqdm')
-rw-r--r--testing/py-tqdm/APKBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/testing/py-tqdm/APKBUILD b/testing/py-tqdm/APKBUILD
index d33808beb2..fa17b67bbc 100644
--- a/testing/py-tqdm/APKBUILD
+++ b/testing/py-tqdm/APKBUILD
@@ -14,6 +14,16 @@ source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname
0001-Import-sleep-nearer-to-usage.patch"
builddir="$srcdir/$_pkgname-$pkgver"
+prepare() {
+ default_prepare
+ cd "$builddir"
+
+ case "$CARCH" in
+ # XXX: Perf tests fail on aarch64 builder.
+ aarch64) rm tqdm/tests/tests_perf.py;;
+ esac
+}
+
build() {
cd "$builddir"
python2 setup.py build