aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-tqdm
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-12-26 19:15:18 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-26 19:15:56 +0100
commite309e699fd2591412601b68c0fe59c77f6d084ef (patch)
treec2fc2e5025e51fb6f1c27b5859076f1e43b48ca4 /testing/py-tqdm
parent37f3ac9ad492ea3342f95aa5ea34f71a1314814f (diff)
downloadaports-e309e699fd2591412601b68c0fe59c77f6d084ef.tar.bz2
aports-e309e699fd2591412601b68c0fe59c77f6d084ef.tar.xz
testing/py-tqdm: fix conflicting files, add version suffix
Diffstat (limited to 'testing/py-tqdm')
-rw-r--r--testing/py-tqdm/APKBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/testing/py-tqdm/APKBUILD b/testing/py-tqdm/APKBUILD
index fa17b67bbc..819b425325 100644
--- a/testing/py-tqdm/APKBUILD
+++ b/testing/py-tqdm/APKBUILD
@@ -2,7 +2,7 @@
pkgname=py-tqdm
_pkgname=tqdm
pkgver=4.19.5
-pkgrel=0
+pkgrel=1
pkgdesc="Fast, Extensible Progress Meter"
url="https://pypi.python.org/pypi/tqdm"
arch="noarch"
@@ -39,17 +39,26 @@ check() {
}
package() {
- mkdir -p "$pkgdir"
+ mkdir -p "$pkgdir"/usr/bin
+ ln -s tqdm-3 "$pkgdir"/usr/bin/tqdm
}
_py() {
local python="$1"
+ local pyver="${python:6:1}"
pkgdesc="$pkgdesc ($python)"
depends="$python"
install_if="$pkgname=$pkgver-r$pkgrel $python"
cd "$builddir"
$python setup.py install --prefix=/usr --root="$subpkgdir"
+
+ cd "$subpkgdir"
+
+ # Add version suffix to executable.
+ mv usr/bin/tqdm usr/bin/tqdm-$pyver
+
+ rm -r usr/man
}
_py2() {