aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/dhex/makefile.patch
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/dhex/makefile.patch
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/dhex/makefile.patch')
-rw-r--r--unmaintained/dhex/makefile.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/unmaintained/dhex/makefile.patch b/unmaintained/dhex/makefile.patch
new file mode 100644
index 0000000000..9e7788b409
--- /dev/null
+++ b/unmaintained/dhex/makefile.patch
@@ -0,0 +1,49 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -1,12 +1,22 @@
+-CC= gcc
+-LDFLAGS= -L/usr/lib -L/usr/local/lib -L/usr/lib/ncurses -L/usr/local/lib/ncurses
++CC?= gcc
++LDFLAGS?= -L/usr/lib -L/usr/local/lib -L/usr/lib/ncurses -L/usr/local/lib/ncurses
+ CPPFLAGS= -I/usr/include -I/usr/local/include -I/usr/include/ncurses -I/usr/local/include/ncurses
+-CFLAGS= -O3 -Wall -std=c99
++CFLAGS?= -O3 -Wall -std=c99
+ #CFLAGS+= -ffunction-sections -fdata-sections
+ #LDFLAGS+= --gc-sections
+ LIBS= -lncurses
+-DESTDIR= /usr/local/
+
++prefix= /usr/local
++bindir= $(prefix)/bin
++mandir= $(prefix)/man
++man1dir= $(mandir)/man1
++man5dir= $(mandir)/man5
++DESTDIR=
++
++MKDIR_P= install -d
++INSTALL= install
++
++
+ OFILES=buffers.o \
+ configfile.o \
+ correlation.o \
+@@ -27,14 +37,11 @@
+ $(CC) $(LDFLAGS) -o $@ $(OFILES) $(LIBS)
+
+ install:all
+- strip dhex
+- cp dhex $(DESTDIR)/bin
+- cp dhex.1 $(DESTDIR)/man/man1
+- cp dhexrc.5 $(DESTDIR)/man/man5
+- cp dhex_markers.5 $(DESTDIR)/man/man5
+- cp dhex_searchlog.5 $(DESTDIR)/man/man5
+-
+-
++ $(MKDIR_P) $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir) $(DESTDIR)$(man5dir)
++ $(INSTALL) -m755 dhex $(DESTDIR)$(bindir)
++ $(INSTALL) -m644 dhex.1 $(DESTDIR)$(man1dir)
++ $(INSTALL) -m644 dhexrc.5 dhex_markers.5 dhex_searchlog.5 \
++ $(DESTDIR)$(man5dir)
+
+ .c.o:
+ $(CC) $< -c -I. $(CPPFLAGS) $(CFLAGS) $(OPTIONS)