aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/z3/APKBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/testing/z3/APKBUILD b/testing/z3/APKBUILD
index a7cdf18c5b..be5ab3f785 100644
--- a/testing/z3/APKBUILD
+++ b/testing/z3/APKBUILD
@@ -29,6 +29,14 @@ build() {
-DCMAKE_C_FLAGS="$CFLAGS" \
..
make
+
+ # Binary for running the unit tests
+ make test-z3
+}
+
+check() {
+ cd "$builddir"
+ ./build/test-z3 -a
}
package() {