summaryrefslogtreecommitdiffstats
path: root/testing/python26-buildutils
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-11-16 10:43:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-11-16 10:47:18 +0000
commit5393a9ac78c5f80d04b224e5e028f99edfcdc24a (patch)
treee60bf6d5cfd017e905d74bbd417f0e05590cf2d8 /testing/python26-buildutils
parentc379c75a623df4823e0593541edc86be9d6aa379 (diff)
downloadaports-5393a9ac78c5f80d04b224e5e028f99edfcdc24a.tar.bz2
aports-5393a9ac78c5f80d04b224e5e028f99edfcdc24a.tar.xz
testing/python26-{setuptools,buildutils}: misc build fix
* avoid fork in global scope * added python-dev to makedepends * quote $pkgdir and $srcdir in case someone have spaces in the path
Diffstat (limited to 'testing/python26-buildutils')
-rw-r--r--testing/python26-buildutils/APKBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/testing/python26-buildutils/APKBUILD b/testing/python26-buildutils/APKBUILD
index 4bee0caa..5db0a6bf 100644
--- a/testing/python26-buildutils/APKBUILD
+++ b/testing/python26-buildutils/APKBUILD
@@ -1,27 +1,23 @@
# Contributor: Andrew Manison <amanison@anselsystems.com>
# Maintainer:
pkgname=python26-buildutils
-_pkgname=`echo $pkgname |sed -e 's,^python26-,,'`
+_pkgname=${pkgname#python26-}
pkgver=0.3
pkgrel=0
pkgdesc="buildutils is a collection of enhancements to the Python distutils"
url="http://pypi.python.org/pypi/buildutils/0.3"
license="GPL"
depends="python python26-setuptools"
-makedepends=""
+makedepends="python-dev"
install=
subpackages=""
source="http://pypi.python.org/packages/source/b/$_pkgname/$_pkgname-$pkgver.tar.gz"
-# append extra dependencies to -dev subpackage
-# remove if not used.
-# depends_dev="somepackage-dev"
-
build() {
- cd $srcdir/$_pkgname-$pkgver
- mkdir -p $pkgdir/usr/lib/python2.6/site-packages
- python setup.py install --root=$pkgdir
- echo "/usr/lib/python2.6/site-packages/$_pkgname-$pkgver-py2.6.egg" > $pkgdir/usr/lib/python2.6/site-packages/$_pkgname.pth
+ cd "$srcdir"/$_pkgname-$pkgver
+ mkdir -p "$pkgdir"/usr/lib/python2.6/site-packages
+ python setup.py install --root="$pkgdir"
+ echo "/usr/lib/python2.6/site-packages/$_pkgname-$pkgver-py2.6.egg" > "$pkgdir"/usr/lib/python2.6/site-packages/$_pkgname.pth
}
md5sums="fec620dee05f591edad386366b52e17b buildutils-0.3.tar.gz"