summaryrefslogtreecommitdiffstats
path: root/testing/wine/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-15 22:00:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-15 22:00:24 +0000
commit026984a0c0bdab7eea63727eced374b77bd56bf2 (patch)
tree262f3ed7ca327d7034b1ed121526ef896ee6361f /testing/wine/APKBUILD
parent0d747c47869f94391f05b5ae07a8cb94844022c8 (diff)
downloadaports-026984a0c0bdab7eea63727eced374b77bd56bf2.tar.bz2
aports-026984a0c0bdab7eea63727eced374b77bd56bf2.tar.xz
testing/wine: moved from x11
Diffstat (limited to 'testing/wine/APKBUILD')
-rw-r--r--testing/wine/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/wine/APKBUILD b/testing/wine/APKBUILD
new file mode 100644
index 00000000..82ecba1b
--- /dev/null
+++ b/testing/wine/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=wine
+pkgver=1.1.36
+pkgrel=0
+pkgdesc="A compatibility layer for running Windows programs"
+url="http://www.winehq.com"
+license="LGPL"
+subpackages="$pkgname-dev $pkgname-doc"
+makedepends="fontconfig-dev openldap-dev libxslt-dev libxxf86dga-dev
+ libxcursor-dev libxrandr-dev libxdamage-dev mesa-dev flex bison"
+# lcms
+source="http://ibiblio.org/pub/linux/system/emulators/$pkgname/$pkgname-$pkgver.tar.bz2
+ 0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -Np1 -i "$srcdir"/0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch
+ ./configure --prefix=/usr --sysconfdir=/etc --with-x
+ make depend || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make prefix="$pkgdir"/usr install || return 1
+ mkdir -p "$pkgdir"/etc/wine
+}
+md5sums="2afa7846175c7c2ce4c7482aa1d82f0f wine-1.1.36.tar.bz2
+63c4a6aee199039d35e6b57fa505e887 0001-Always-adjust-the-color_shifts-pointer-when-SelectBi.patch"