aboutsummaryrefslogtreecommitdiffstats
path: root/community/xapian-core
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-08-18 16:14:41 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-08-18 17:43:19 +0200
commitac5833d64ef8f526fb0e62a04dc371c769674fb0 (patch)
tree4bfe37ef54dd961b8a4f94a05bcf7f90c981dd8d /community/xapian-core
parenta6710a9157152319951686889f97127ecf5370d5 (diff)
downloadaports-ac5833d64ef8f526fb0e62a04dc371c769674fb0.tar.bz2
aports-ac5833d64ef8f526fb0e62a04dc371c769674fb0.tar.xz
community/xapian-core: add check function
Diffstat (limited to 'community/xapian-core')
-rw-r--r--community/xapian-core/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/community/xapian-core/APKBUILD b/community/xapian-core/APKBUILD
index 2af54f2526..4e49a90e42 100644
--- a/community/xapian-core/APKBUILD
+++ b/community/xapian-core/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=xapian-core
pkgver=1.4.4
-pkgrel=0
+pkgrel=1
pkgdesc="Open source search engine library"
url="http://www.xapian.org/"
arch="all"
@@ -28,6 +28,10 @@ build() {
make
}
+check() {
+ make VALGRIND= -C "$builddir" check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install