aboutsummaryrefslogtreecommitdiffstats
path: root/main/pcre
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-08-28 10:44:16 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-08-28 10:46:14 +0000
commit09af97b822c64b353bebbf6c3b76b90eb091728d (patch)
tree529ef723849a10715b6bb06c1d658ca9c2fdf3b2 /main/pcre
parent38d68285cae7efaa99e98e72e67d1b9c10012f4a (diff)
downloadaports-09af97b822c64b353bebbf6c3b76b90eb091728d.tar.bz2
aports-09af97b822c64b353bebbf6c3b76b90eb091728d.tar.xz
main/pcre: fix tests on platforms without JIT
make paxmarking optional
Diffstat (limited to 'main/pcre')
-rw-r--r--main/pcre/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/main/pcre/APKBUILD b/main/pcre/APKBUILD
index 7d9e8896d8..d8b41d5e3a 100644
--- a/main/pcre/APKBUILD
+++ b/main/pcre/APKBUILD
@@ -50,8 +50,11 @@ check() {
cd "$builddir"
# paxmark tests requiring JIT
- ./pcre_jit_test &>/dev/null || ./pcretest &>/dev/null < /dev/null || true
- paxmark -m .libs/lt-pcre_jit_test .libs/lt-pcretest
+ for fn in pcre_jit_test pcretest; do
+ ./$fn &>/dev/null < /dev/null || true
+ [ .libs/lt-$fn ] && paxmark -m .libs/lt-$fn
+ done
+
# skip locale specific tests
sed -i -e 's/do3=yes//g' RunTest